Provider Submissions: Down for maintenance

Incident Report for Unity

Resolved

Provider submissions are functioning again. Please let us know if you experience any issues.
Posted Sep 03, 2025 - 09:05 MDT

Identified

Starting at 1pm Tuesday SUD provider submissions will not be accepted through the Provider Submissions module. We will post an update once this is available. UI entry is still allowed.
Posted Sep 02, 2025 - 13:05 MDT
This incident affected: Unity - Provider Submissions.