The Provider Submissions module is now fully operational and processing jobs as expected. Thank you for your patience while we resolved the outage. If you experience any further issues, please contact support.
Posted Dec 15, 2025 - 12:54 MST
Update
We are continuing to investigate this issue.
Posted Dec 15, 2025 - 12:38 MST
Investigating
The Provider Submissions module is currently experiencing an outage and is not processing jobs at this time. Our team is actively monitoring the situation and working to restore functionality. We will provide an update as soon as the issue is resolved
Posted Dec 15, 2025 - 12:37 MST
This incident affected: Unity - Provider Submissions.